GS1900-24E - no Webgui after firmware upgrade


GS1900-24E is not responding to Webgui after firmware upgrade (C0\GS1900-24E-2.40(AAHK.2)C0.bix)

I updated via Webgui with HTTP method. After some time the Gui offered rebooting, which I confirmed.

After that the webgui is not reachable any more. I tried the static ip address as well as with no success. DHCP is also no registering that device.

Then I tried ZON, but that can't detect the switch either.

Basic switching functionality is working, as connected devices get an active gigabit link and can exchange data.

What about the buttons and jumpers on the PCB?

S1 is the front switch (reset)

S2 is a hidden switch to the side (reachable from the left side through a air vent hole)

T1 is a jumper on the PCB

Do these things help to re-animated the management?

Any idea how to proceed?


  • Haaah,

    already got it.

    Found the gui with a IP scanner. The switch changed setting to DHCP and got .55!

    So I was able to access it and set the new (correct) static address.

  • Zyxel_LuciousZyxel_Lucious Zyxel Official Agent Posts: 223  mod
    edited September 2, 2019 4:46PM

    Hi @GuntherN

    Welcome to Zyxel community.

    Zyxel switch will firstly try to use DHCP as management if the switch is factory default or reset to factory default. If DHCP is not available, the switch will then go as fixed IP

    Glad that the issue is resolved.


Sign In to comment.