XGS2210-28 V4.50(AAZJ.0): VLAN configuration via console broken?

VeitVeit Member Posts: 20  Freshman Member
Hello!

We need assistance for configuring VLANs via console:
Enabling VLAN TX tagging does not work for us when using the console, while it works well using the web interface.

Example:

Interfaces 21-24 shall be configured for VLAN tagging. They are already configured for frame-type tagged:

...
interface port-channel 21
  name Tagged1
  pvid 10
  ingress-check
  frame-type tagged
  green-ethernet auto-power-down
  green-ethernet short-reach
exit
interface port-channel 22
  name Tagged2
  pvid 10
  ingress-check
  frame-type tagged
  green-ethernet auto-power-down
  green-ethernet short-reach
exit
interface port-channel 23
  name Tagged3
  pvid 10
  ingress-check
  frame-type tagged
  green-ethernet auto-power-down
  green-ethernet short-reach
exit
interface port-channel 24
  name Tagged4
  pvid 10
  ingress-check
  frame-type tagged
  green-ethernet auto-power-down
  green-ethernet short-reach
exit
...

But when I try to remove those ports from the untagged list in the VLANs, the changes are ignored:

$ ssh [email protected]
[email protected]'s password:
Copyright (c) 1994 - 2017 Zyxel Communications Corp.
coreswitch25# show vlan 20
  802.1Q VLAN ID : 20
  Name         :LAN
  Status      : Static
  Elapsed Time   :    0:40:28
 
  Port Information Mode
  ---------------- ----
     1             Untagged
     2             Untagged
    19             Untagged
    20             Untagged
    21             Untagged
    22             Untagged
    23             Untagged
    24             Untagged
    25             Tagged
    26             Tagged
    27             Tagged
    28             Tagged
  
Default Gateway : xxx.xxx.xxx.xxx
coreswitch25# config
coreswitch25(config)# vlan 20
coreswitch25(config-vlan)# untagged 1-20
coreswitch25(config-vlan)# exit
coreswitch25(config)# exit
coreswitch25# show vlan 20
  802.1Q VLAN ID : 20
  Name         :LAN
  Status      : Static
  Elapsed Time   :    0:41:12
 
  Port Information Mode
  ---------------- ----
     1             Untagged
     2             Untagged
    19             Untagged
    20             Untagged
    21             Untagged
    22             Untagged
    23             Untagged
    24             Untagged
    25             Tagged
    26             Tagged
    27             Tagged
    28             Tagged
 
Default Gateway : xxx.xxx.xxx.xxx
coreswitch25# exit

When I edit VLAN 10 in the web interface and check the "TX Tagging" box for interfaces 21-24, and compare downloaded config files before and after this edit, a diff shows that this one and exact change has been made and nothing else:

Before:
...
vlan 20
  name LAN
  normal ""
  fixed 1-2,19-28
  forbidden 3-18
  untagged 1-24
exit
...

After:
...
vlan 20
  name LAN
  normal ""
  fixed 1-2,19-28
  forbidden 3-18
  untagged 1-20
exit
...

Also downloading the config, changing the untagged list, and re-uploading the config, does the trick successfully.

Am I missing something or did I hit a firmware bug?
Also I am quite confident that this problem did not exist in FW 4.40.

Best regards,
// Veit

Best Answers

  • VeitVeit Member Posts: 20  Freshman Member
    Accepted Answer
    I am sorry, I just realised that a new untagged line will not replace the old one, so I need to use no untagged to remove ports from the list instead.

All Replies

Sign In to comment.