Are there problems with Voice VLAN functionality with the GS1920-24HPv2 Nebula Flex switch?

CSmith_STCCSmith_STC Member Posts: 12  Freshman Member
A new GS1920-24HPv2 switch has been installed in a customer site and it is set up so that the main LAN uses VLAN 1. A voice VLAN has been set up to use VLAN2. Each VLAN has a separate gateway router providing internet connectivity. The MAC of the phone connected to this voice VLAN is showing in VLAN2. The gateway router for this VLAN is assigned to VLAN2 but the phone gets a DHCP address from the gateway router in VLAN1. 

Can anyone suggest a reason for this?

Thanks
«1

Answers

  • iversivers Member Posts: 22  Freshman Member
    Have set the correct OUI and is the phone Vlan detected set the correct Vlan tag?
  • CSmith_STCCSmith_STC Member Posts: 12  Freshman Member
    Hi @ivers
    The OUI is correct and when monitoring the client connections the device's MAC is shown in VLAN2, the voice VLAN. 

    Thx
  • iversivers Member Posts: 22  Freshman Member
    Is the port which connected phone set as trunk or access? How about switch to access to do the cross check, if the phone get the other Vlan subnet.
  • CSmith_STCCSmith_STC Member Posts: 12  Freshman Member
    Hi @ivers
    As I have always done the ports are set to access with their PVID = 1 
    The switch just isn't putting the defined OUI in to the voice VLAN correctly.
    Using trunk port configuration causes issues with the PCs as they have a chance of picking up an address from the Voice VLAN DHCP server.

    Thanks, I'm going to have to log a fault.

    Chris
  • Nebula_JasonNebula_Jason Zyxel Official Agent Posts: 91  mod
    Hi @CSmith_STC,

    To have more detail and check the configuration for you, I will PM you later.
    Please help to check your Inbox.

    Thanks.
    Jason
  • CSmith_STCCSmith_STC Member Posts: 12  Freshman Member
    Hi @Nebula_Jason
    I have added the Admin user account to the organisation "Bishopsgate CF" you requested.

    Regards

    Chris
  • Nebula_JasonNebula_Jason Zyxel Official Agent Posts: 91  mod
    Hi @CSmith_STC ,

    After checking the configuration of VLAN, I find that you configure type Access on your both uplink ports(From your port name, I assume they are port 1 and port 2) and port 1 with PVID 1, port 2 with PVID 2.
    It will make the packets from VLAN 1 or 2 will be untagged out to your uplink gateway.
    Therefore, I recommend you to configure both ports with type Trunk and you may configure the PVID that you don't use such as PVID 3.

    Hope it helps.
    Jason
  • CSmith_STCCSmith_STC Member Posts: 12  Freshman Member
    Hi @Nebula_Jason
    This doesn't make any sense.
    There is no where to specifically configure what VLAn a port should be assigned to from the NCC.
    Therefore I have to assume that traffic is allocated to a VLAN based on the port settings of Access or Trunk and the PVID.

    I want port 1 to sit in VLAN1 only and for the switch to only put traffic in VLAN 1 hence the PVID=1
    I want port 2 to sit in VLAN2 only and for the switch to only put traffic in VLAN 2 hence the PVID=2

    Setting each to trunk with a PVID=3 makes no sense and I would expect traffic to be broadcast to both VLANs in this case. This would definitely cause a DHCP server race.

    Can you please clarify what "DHCP Server Guard means" in the switch configuration page?

    Are further VLAN configuration options going to be available in later software updates.
    The lack of options is very restrictive at present and is adding to the confusion over what the switch is doing.

    Once we have agreed on this topic I would like to return to the Voice VLAN issue, and the fact that the switch isn't putting specific MACs in to the correct VLAN.

    Thank you

    Chris
  • RUnglaubeRUnglaube Member Posts: 109  Ally Member
    Are the gateways doing VLAN tagging? If so, why don't you use Trunk type? In trunk type you can still define the PVID (similar to native VLAN) and define the vlans you want to allow to pass.
    "You will never walk along"
  • CSmith_STCCSmith_STC Member Posts: 12  Freshman Member
    Hi @RUnglaube
    There should be no need to use tagging on the ports connected to the gateways. Thanks for your comment. We're moving away from the core issue of this discussion which is that the Voice VLAN function isn't working.

    Kind regards 

    Chris
Sign In to comment.