How can I bypass the wizard on VPN2S?

Apparently, this thing (VPN 2S) REALLY wants me to go through the wizard and get updated firmware, et al. While a nice thought, my device is NOT connected to the internet, so I can't download the firmware. And, I can't get out of it. I'd really like to preconfigure this thing before I get to my client site, so I'm not kicking them offline while I figure out how to do this. Please tell me there's a way around the "wizard." While it's a lovely thought, I don't think it's quite as thoughtful as intended.

All Replies

  • Zyxel_JerryZyxel_Jerry Zyxel Official Agent Posts: 276  mod
    edited February 6, 2020 9:31AM

    Hi @DHLewis

    Welcome to Zyxel Community

    I’m not sure which firmware you current using,

    Before the firmware version 1.09(ABLN.0), it could not canceled the wizard on VPN2S.

    You can use local firmware upgrade to the latest firmware version.

    I’ll send you the latest firmware in private message.

  • Jerry, I'm glad to hear the cancellation option is now integrated into the setup. That should help others going forward. But, it put me into a that I've upgraded it, I can only connect using my mac and safari browser. I wouldn't mind too much, but, this is for a client whom I support remotely 80% of the time, and they have no macs/safari options in the building. from what I read, it appeared that there may be some certificate or other security "enhancements" that may be preventing access; alternatively, the message about "enabling java" is troubling, as few browsers support java (ie & safari being the only two I know of).

    is there a non-java interface option? or some other mechanism (perhaps a dedicated management app) that would streamline connectivity? Any assistance on that would be greatly appreciated! From what I've seen, I'm liking the looks of the firewall, and would like to make it my "go-to" for my smaller clients. But, I've burned a fair number of hours just in trying to get back to the interface.

    Thanks again!


  • Jerry, to follow have my most sincere and heart-felt thanks! The firmware you sent me was the same as what I got during the setup/update. However, something is clearly different, as all of my browsers (apple & windows) are connecting. would like it connect a little faster, but, right now, I'm very happy to see what I'm seeing. The firmwares are the same releases. I don't know if I got corrupted download or if thre's a slight difference between what you sent, and what my unit found on the auto-update. (might be worth snooping; if they are different, i'd suggesting making the one you sent available to the auto-update sessions)

    At this point, I seem to be getting good response time, and consistent access to the interface.

    Thank you so much!


  • Zyxel_JerryZyxel_Jerry Zyxel Official Agent Posts: 276  mod

    Hi @DHLewis

    We’re glad to hear that the problem is solved on your site.

    The firmware on auto-update is the same with the firmware I sent it to you.

  • Maxim_LMaxim_L Member Posts: 4


    Hopefully you can help me with a similar issue as well, as it's getting worse.

    I wanted to bypass the wizard as in the original case so downloaded and installed the latest firmware. I went OK and later I managed to configure necessary things and get internet access.

    Now, whenever I'm trying to connect to the GUI interface of VPN2S it becomes veeery slow as described in the previous case. If switch between the browsers it helps for some period of time, but then it comes back to the same very slow GUI performance.

    I need to configure VPNs but with such a GUI performance it makes it impossible to do any setup on VPN2S.

    I tried various browsers on various machines and having the same result with GUI interface being very slow or even unreachable beyond the login screen with a successful login (password accepted).

    Feedback is much appreciated.

  • On top of what has been previously described.

    It looks like the issue is with extremely high CPU usage - when finally I can see the dashboard, it shows 99% CPU Usage.

    BUT It doesn't matter if I remove a WAN cable or not (trying to eliminate any internet traffic), the CPU usage remains that high.

    I've also tried to reset it and come back to factory settings, then downgraded to the previous firmware version (1 version down). Still the same issue with poor GUI performance.

  • Zyxel_JerryZyxel_Jerry Zyxel Official Agent Posts: 276  mod

    Hi @Maxim_L

    The firmware is sent to you in private message.

  • Maxim_LMaxim_L Member Posts: 4


    The new firmware didn't help much, but in the meantime I investigated the issue.

    If I connect via HTTP the device CPU usage goes to 99-100% and everything becomes slow.

    If I do the same with HTTPS even without a normally issued certificate, the connection is OK and CPU usage is very low.

    There seems to be an error in the code which leads to CPU overload when connecting via HTTP.

  • Zyxel_JerryZyxel_Jerry Zyxel Official Agent Posts: 276  mod

    Hi @Maxim_L

    I’ve sent the firmware to you via private message.

Sign In to comment.