XGS3700 - intermittently slow responses to pings

imaohwimaohw Member Posts: 89  Ally Member
edited October 18, 2020 6:07AM in Discussions
I was making some changes to the configuration of my XGS3700 switch stack and experienced occasional slow loading of pages in the web user interface.  Sometimes taking as long as 2-3 seconds for a page to load.

I decided to run a continuous ping from a PC connected to the XGS3700 stack and saw intermittent slow response times. See below:


 
I logged into the switch thru SSH and displayed the CPU utilization using "show cpu-utilization".  The utilization was much higher than I would have expected.  There was very little network traffic at the time. All of the downstream switches (GS2210, GS1900, GS1350, GS1910) were showing CPU utilization of less than 10% (most at 1-2%). See XGS3700 CPU utilization output below:



To try and narrow down the high utilization I used the "show cpu-utilization process" which according to the CLI manual should provided CPU and memory usage per process.  However this command displayed exactly the same results as "show cpu-utilization". No detail information.

I may be wasting my time looking into this as I do not see any issues with network traffic flowing thru the XGS3700 stack. However, I get concerned when I see instances of CPU utilization of over 80% and when there is slowness in the XGS3700 web UI and the ping latency. I am curious about the following:
  • Why does the CLI command "show cpu-utilization process" not work as documented?
  • Where should I be looking to better understand the intermittent latency in ping responses from the XGS3700?
  • Are the CPU utilization statistics from the XGS3700 stack combining all CPUs from all switches in the stack or only from the "master" switch? 
  • Are all CPUs used when there are multiple switches or just the master's CPU?
  • Should I be concerned with the CPU utilization percentages?

All Replies

  • Zyxel_LuciousZyxel_Lucious Zyxel Official Agent Posts: 224  mod
    edited October 20, 2020 1:11PM
    @imaohw

    1. 
    CLI reference guide is a "generic" document which cannot be 100% precisely applied to every model.
    See the note on first page: some command options in this guide may not be available in your product.

    2.
    In older ZYNOS software like 4.30 on XGS3700 series, the priority of ICMP process in CPU queue is rather low than newer firmware. It seems to us this could be the cause of intermittent latency.

    3.
    In stacking operation, master slot's CPU handles most tasks except for particular ones such as DDMI info polling from transceivers.

    4.
    As long as there is no impact in significant ways, the CPU utilization seems okay.

    Zyxel_Lucious

Sign In to comment.