AP Zyxel NWA5121-NI drops connections

Hi all,

I have a Zyxel NWA5121-NI set up as an AP. Yet when a few devices connect to it (like only 2 or 3), it randomly drops the connection with those devices. The wifi connection completely disconnects. After a bit you can connect again. It happens randomly, sometimes you can go a day without it occuring. 

I assume it happens when an extra device connects to the AP. Load balancing is not active on the AP, it is the only AP in the building. In the log there is an error code 14. 

Also in the log (but not per se related to the above I think):
Port 0 is down!
Station has disassoc. Interface:wlan-1-1 Station: 18:56:80:7D:EC:F4
Station has deauth. reason 3 Interface:wlan-1-1 Station: FF:FF:FF:FF:FF:FF

Thanks!
«1

All Replies

  • Nebula_FredaNebula_Freda Zyxel Official Agent Posts: 220  mod

    May I know the version of the NWA5121-NI, and would you share the complete log and the issue happened time to me via PM? What's the client you used for connection and is that only one client this this situation?
  • DeefeesDeefees Member Posts: 9
    What do you mean exactly with the version? Below image of the bottom of the device.

    There is no issue when one desktop PC and a payment terminal are connected. When a extra laptop pc is connected, the issue occurs and the AP drops the connections.

    I'm not at the location right now so I'll get back to you asap with a full log and extra info I can see when I log on to the device.

    Thanks!

  • Nebula_FredaNebula_Freda Zyxel Official Agent Posts: 220  mod
    You can check the version in the AP web GUI after logging it via the AP's IP address.
    The version is shown on the dash board.
    Would you help to collect the diagnostic of the AP and provide to us?
    The diagnostic can be collected in MAINTENANCE> Diagnostics> Diagnostics.
    Please also share the issue happened time for us and we'll check the debug logs of the client MAC in your 1st post.
    Thanks.
  • Nebula_FredaNebula_Freda Zyxel Official Agent Posts: 220  mod
    After we checked the logs and diagnostic info, the reason code 14 means the wireless authentication is not done. There's a issue about the authentication failed in the old version and it has been fixed in newer version. We suggest to upgrade the AP to the last version which can be downloaded in below link:
    After download the firmware, you can go to MAINTENANCE> File Manager> Firmeware Package> Upload File and upgrade it.
    If the issue still happens after the firmware upgrade, it might be caused by the interference in 2.4GHz.
    We recommend to do below two configuration changes to enhance the connection.
    1. Enable DCS and disable DCS client aware: The DCS can help to select a better channel with less interference of the 2.4GHz. However, when the DCS client aware is enabled, the DCS will not do anything event there's a better channel when there's a client connected on the AP. So, please select a time without service impact to do the DCS without enabling the DCS client aware.
    2. The security profile of the SSID change to WPA2-AES. When using the WPA2-TKIP, the data rate will be limited in 54Mbps, however, if the client's capability is 802.11n, it can up to 300Mbps (based on the environment status), so if there's no specific client to require WPA2-TKIP, you may use the security of the SSID to WPA2-AES to get better link speed to avoid any transmission issue to cause the authentication failed.
    Thanks.
  • DeefeesDeefees Member Posts: 9
    Thanks @Nebula_Freda for the detailed solution.
    I will try this and report back!
  • DeefeesDeefees Member Posts: 9
    FYI, there is one payment terminal device connected, I'm not entirely sure, but I think that one requires TKIP. Would it help to set up a different SSID just for that one and another SSID for the devices that are able to handle a better protocol? 
  • Nebula_FredaNebula_Freda Zyxel Official Agent Posts: 220  mod
    edited August 3, 2020 4:28PM
    Hi @Deefees ,
    The data rate will be limited on the devices which connected on the SSID with WPA2-TKIP security. So if you use the security for only one device and use the other SSID with WPA2-AES for the other devices, the data rate of the other devices can upper than 54Mbps.
    May I know is the disconnection issue resolved after you upgraded the firmware?
    Thanks.
  • DeefeesDeefees Member Posts: 9
    I did the update of the AP tuesday and right there and then it seemed to be ok but I wasn't really capable to test extensively.

    Today I hear that the disconnection issue happened again yesterday evening while just browsing. I still can try the DCS option though because adjusting the default setting wouldn't let me save it so I'll have to create new settings probably. I will check the log again and let you know when I have more information.
  • DeefeesDeefees Member Posts: 9
    Could it be that the firewall/switch needs an update as well and could that impact the AP? There is a Zyxel USG 40 and a Zyxel GS1920-24 and it's firmware is probably very outdated as well. 
  • Nebula_FredaNebula_Freda Zyxel Official Agent Posts: 220  mod
    Hi @Deefees ,
    If there's the disconnection issue happened, please provide the diagnostic, issue happened time and the station MAC address for us to check details. 
    May I know that is the wired client can't access the internet as well when the wireless issue happened since you mentioned to upgrade the USG40 and GS1920-24 firmware? 
    Anyway, no meter the wired client has issue or not, we suggest to upgrade the firmware to the last version that is released for some fixed bugs and some enhancement. Here's information for your reference.
    USG40
    Please click the download icon, and after you log in the MyZyxel account, you can download the 4.38(AALA.0)C0: https://www.zyxel.com/support/DownloadLandingSR.shtml?c=gb&l=en&kbid=M-01438&md=USG40#searchZyxelTab4
    GS1920-24
    The last version is 4.50(AAOB.3)C0, and it can be downloaded in below link.
Sign In to comment.