Nat port does not work

I cant configure nat in my usg40.
I'd like to active xampp SERVER to my host ip 192.168.8.port 20200
I'm trying all internet guide and video  but nothing.

in source IP I tried WANIP and any (in all interne guide NAT there are original IP and mapped IP, here is source IP, external IP and internal IP), in port mapping I tried Port (like above image) and services 



any help?
thanks

All Replies

  • Zyxel_StanleyZyxel_Stanley Zyxel Official Agent Posts: 718  mod

    Hi @serverpal  

    You would like to forward 20200 to internal server.

    So it have to also add policy control rule for allow 20200 from WAN to LAN.

    Can you make sure your service port is 20200?    (HTTP default port is 80) 

    And also source IP address shouldn’t WAN1 IP address….except you already known client IP address.


    serverpal
  • serverpalserverpal Member Posts: 13
    hi @Zyxel_Stanley
    thank you, 

    I just can't fix it.

    ISP ROUTER ports 20200 connect to 192.168.1.237

    ISP router 192.168.1.1 connect to USG40 WAN1 192.168.1.237

    USG LAN1 192.168.8.1

    my xampp server 192.168.8.7

    inside lan from pc 192.168.8.50 by browser I type 192.168.8.7:20200 and I see xampp dashboard (web server works inside lan).

    but nothing, from outside (http://xxx.xxx.xxx.xxx:20200) I cant see my server web

  • PeterUKPeterUK Member Posts: 634  Guru Member
    edited July 1, 2020 8:13PM
    Can you put you ISP router in modem mode/bridge mode so the USG has the WAN IP?
    serverpal
  • Zyxel_StanleyZyxel_Stanley Zyxel Official Agent Posts: 718  mod

    Hi @serverpal

    Your USG is behind  the other NAT route. (double NAT) 

    You have to create port forwarding on ISP router first.

    External IP:XX.XX.XX.XX(Public IP), Mapping IP: 192.168.1.237, External Port: 20200, Mapping port: 20200.

    Of cause you must make sure ISP router is able forward traffic to USG. 

     

    On USG:

    NAT Rule:

    External IP:192.168.1.237, Mapping IP: 192.168.8.7, External Port: 20200, Mapping port: 20200.

    The policy control rule can configure as the same as I posted to you before.

    serverpal
  • serverpalserverpal Member Posts: 13
    hi,
    my isp router is managed from my ISP company (I cant to access it).
    NAT SOLVED,
    ISP company told me that open port has about two days of work and now I can connect to my server.
    Thanks to all, you have been very helpful !
  • Zyxel_StanleyZyxel_Stanley Zyxel Official Agent Posts: 718  mod
    Hi @serverpal

    It's good to know your issue has resolved. :+1:
    serverpal
Sign In to comment.