It's impossible to upgrade firmware for USG110 V4.10

FrankLauerFrankLauer Member Posts: 18  Freshman Member
edited January 13, 2020 6:39PM in ZyWALL USG Series

Since years I try to update the firmware for an old USG110 but it never worked.

  • I made a hardware reset (reset button).
  • I have FW1: V4.10(AAPH.0) 2014-05-08 FW2: N/A
  • I downloaded FW from USG110_4.10(AAPH.1)C0, USG110_4.10(AAPH.2)C0 and USG110_4.11(AAPH.2)C0

When I try to upgrade the firmware by webpanel after the upload the USG try to boot and than it stucks. The LED is always blinking. Only reconnecting the power helps.

When I upload the FW bin with FTP the USG reboots but I still don't have the new firmware. Instead I have in log and on frontpage the message 'Previous firmware update failed!!'

It doesn't matter which of the above FW versions I try.

After 6 years we really need to update! What need I to do?

Accepted Solution

  • FrankLauerFrankLauer Posts: 18  Freshman Member
    Accepted Answer


    I tried today another form of update with USB stick. And after different tries and resets and reboots the firmware upgrade magically happens ;)

    It's strange because it was always the same bin file.

    However now I'm on 4.35. It's done :)

All Replies

  • Zyxel_JerryZyxel_Jerry Zyxel Official Agent Posts: 215  mod

    Hi @FrankLauer

    Good to know that you had upgrade the firmware successfully.

    And yes it is strange if you were using the same bin file in different upgrading methods.

    It will be helpful if you have the console connected during the failure upgrading process.

Sign In to comment.