GS1900 series - understanding QoS, Remark options and Trust Mode

WvandeHoefWvandeHoef Member Posts: 19  Freshman Member

Is there a clear explanation document available on how QoS works on the GS1900 series on both normal untagged ports, tagged ports and trunks?

I am having a network behind an USG60 where the first GS1900-24E has an uplink to one GS1900-8HP for 3 NWA1123-ACv2 and 2 IP cameras, another uplink to one GS1900-8 connected to pc's and a printer and another uplink to a second GS1900-24E on a different floor. On every trunk 4 vlans are transmitted (guest/dmz/lan1/prio), but only lan1 and guest are forwarded to the AP.

Users where forced to start using Jabber client on their phones and started complaining about the voice quality. As they are using Android and iPhone I was unable to implement a voice VLAN and separate it on the OUI and I wanted to implement QoS to raise the priority of the phones.

The NWA1123-ACv2 have been set to WMM in the SSID profile and indeed send the call stream with AF41, but after the first switch the packed has DSCP: CS1 and I do not understand why.

I have played with the different QoS settings capturing packet streams using the mirror function, but am unable to force a different DSCP for streams to/from a single port.

My questions:

Under the Trust menu option:

Trust Mode: what mode is best used in my configuration? CoS, DSCP or Cos-DSCP? My best guess is DSCP.

Trust/Untrust: does this setting tell the switch to trust or not trust the DSCP level that is send by the device connected to that particular port?

Under the General menu option:

What do the QoS Remark / DSCP Remark / IP Precedence Remark actualy have as an effect when enabled/disabled? Do they rewrite that specific remark to the value entered in the first field?

For an uplink/trunk between two GS1900 devices: what should be set for the QoS?

I hope someone can help me out on these questions?




All Replies

  • WvandeHoefWvandeHoef Member Posts: 19  Freshman Member

    The network in use is a bit like the above.

    In the USG60 I have given the rules that apply to the Jabber traffic the highest prio and SIP communications do get the highest priority.

  • RichardHanRichardHan Member Posts: 29  Freshman Member


    For QoS information, I share my knowledge and opinion below:

    1. WMM is the QoS settings for wireless, it won't change any DSCP value for data packets sent from AP to first switch.
    2. QoS takes effect when traffic congestion or under high loading, if the traffic in customers environment is not heavy (<50% allowed throughput), change QoS settings won't improve too much.
    3. For the switch port, since most traffic should occur on Layer 2, it's more recommended to better set "CoS", so that when switch forwarding those packets, the CoS settings will be taken account of.
    4. Actually, you have to consider QoS settings on both incoming(from WAN) and outgoing(from AP) packets, make sure the "first switch" can modify received packets with correct QoS value. After the packets forwarded out, the next switch can handle them in correct order.
    5. Besides, you can set Bandwidth management on the USG, so that those voice packets will be sent to WAN in higher priority.

    Also, I've some questions when analyzing this issue, it'll be great if you can answer them:

    1. Is the bad performance only appeared on voice call? or also the Ethernet device suffers for high latency connecting to Internet?
    2. Bad Voice Quality could be also caused by interference in wireless environment, could you please share the radio settings on AP with us? (for the radio that Voice SSID uses)

    Keep in touch, and glad to help you :)

  • WvandeHoefWvandeHoef Member Posts: 19  Freshman Member

    Thanks Richard.

    As I am off-site today I will have to come back in more detail later, but for now my main issue is that voice call packets that originate from the AP with DSCP set to AF41, reach the USG60 with the DSCP changed to CS1 and are transmitted to the Cisco Jabber network with that level. Return packets from Cisco on the WAN side also have DSCP set to AF41 and are forwarded by the USG60 to the first GS1900-24E with DSCP still intact as AF41, but somehow reach the GS1900-8HP and the AP with DSCP changed to CS1.

    Therefore my question how to correctly set the QoS for the uplink?

    Currently I have these settings:

    CoS Value = 0 / Cos Remark = disable / DSCP Remark = disable / IP Precendece Remark = disable

    Trust Mode = DSCP / Port Mode = Trust

    N.B. To make sure the wireless coverage is not the issue I had one user use the windows client of Jabber from his laptop that is wired to the same GS1900-8HP switch as the AP is connected to and he also has short interruptions in the calls, but not as bad as the wireless jabber connection. As the Windows Jabber client is transmitting though a Cisco AnyConnect VPN I cannot do a proper packet analyses though.

    I have not heard any complains about normal ethernet performance, the WAN connection is a 60/30Mb VDSL and speedtests from both wired and wireless show good values (Ping 7/Download 50Mb/Upload 30Mb on the 5G Wifi and lower on the 2.4G Wifi). There are 4 AP's that kickoff clients based on RSSI level and on all spots the signal strength 55dBm.

    Youtube video is continuous on both wired and wireless. The only issue reported is in voice calls. I had one complaint about Whatsapp voice calls having short interruptions. but I ignored that one as I expected that WA network to be more congested and of lower quality. As the Gigaset DX800A VOIP PABX never gave any voice quality issues and it is behind the second GS1900-24E I did not think about enabling QoS at all, until the Jabber users started complaining. The funny thing is that Jabber calls do not loose packets, there is just a short delay between packets and then the sentence continues where it was interrupted. Therefore I wanted to enable QoS on the switches to prioritize these packets.

  • WvandeHoefWvandeHoef Member Posts: 19  Freshman Member

    Please find below the radio settings for one of the 4 AP's. All have the same settings, apart from the channels. Those are manually selected over 3 bands and the ones that are the most sways from each other do have the same channel setting. There was an error displaying this embed.

  • WvandeHoefWvandeHoef Member Posts: 19  Freshman Member

    I have now disabled QoS on all switches, setting all ports as follows:

    and with these settings the Jabber call is reaching the USG60 with DSCP: AF41. Also Whatsapp calls do reach the USG60 with the original DSCP flag.

    So this results in my original question:

    with reference to the above Application Diagram: what should I set in the GS1900-8HP and GS1900-24E switches to manually force a CoS value of 5 for port 2 of the GS1900-8HP so that the the CoS value of 5 will be forwarded by the GS1900-8HP over the trunk port (1) to the GS1900-24E (port 4) and then to the USG60 that is connected to port 1 of the GS1900-24E?

    On the GS1900-8HP:

    Cos Value of Port 1 (uplink) = ?

    Remark CoS = Disable or Enable?

    Remark DSCP = Disable or Enable?

    Remark IP Precendence = Disable or Enable?

    Cos Value of Port 2 (computer) = 5

    Remark CoS = Disable or Enable?

    Remark DSCP = Disable or Enable?

    Remark IP Precendence = Disable or Enable?


    Trust Mode = Untrusted/CoS/DSCP/CoS-DSCP/Precedence ?

    QoS Port 1 (uplink) = Trust or Untrust?

    QoS Port 2 (computer) = Trust or Untrust?

    On the GS1900-24E:

    Cos Value of Port 1 (uplink to USG60) = ?

    Remark CoS = Disable or Enable?

    Remark DSCP = Disable or Enable?

    Remark IP Precendence = Disable or Enable?

    Cos Value of Port 4 (uplink to GS1900-8HP) = ?

    Remark CoS = Disable or Enable?

    Remark DSCP = Disable or Enable?

    Remark IP Precendence = Disable or Enable?


    Trust Mode = Untrusted/CoS/DSCP/CoS-DSCP/Precedence ?

    QoS Port 1 (uplink to USG60) = Trust or Untrust ?

    QoS Port 2 (uplink to GS1900-8HP) = Trust or Untrust ?

  • RichardHanRichardHan Member Posts: 29  Freshman Member


    For wireless configuration, I suggest you to change 5G radio channel width to 20MHz(reduce the chance to be interfered), and set DCS on both 2.4G/5GHz radios.(fixed channel is okay when everything is under control, but the real wireless environment is dynamic and always changing, it will be good if you set DCS, then AP will dynamically select channels with least interference.)


    FYI, the link below is the configuration guide of Voice over Wi-Fi application.


    Best Regards,


  • WvandeHoefWvandeHoef Member Posts: 19  Freshman Member

    Thanks Richard for your reply. I will check out that application note.

    As I do have issues with Jabber for Windows as well from the computer at port 2 that is connected via Cisco Anyconnect VPN to the corp network, can you please answer the QoS question as well?

  • KimKim Member Posts: 4

    If you enable remark DSCP, you have to configure both uplink and downlink to trust and then QoS will work normally.

    For trust mode, I will configure CoS-Dscp to trust both types.

    Also, you have mentioned that after disabling QoS the packet will be transmitted with AF41 is because the switch only forward the packet instead of changing its priority

    hope this will be helpful to you

  • Have you checked if traffic congestion happened when voice quality became worse? I think you should check it before configuring QoS because QoS takes effect when ingress traffic is congested. You can observe how many bytes the interface RX counter (ifInOctets) increase per second. If it's much less than 1Gbps (about 125MB/s), I don't think configuring QoS can solve voice quality problem......

    According to your application diagram, I will check port 2 of the GS1900-8HP and port 1 of GS1900-24E which connects to USG60.

    If traffic congestion happened, I will configure both ports as trust mode (as Kim mentioned that you should configure it for both uplink traffic and downlink traffic), set trust mode as CoS-DSCP, and enable both 'Remark CoS' and 'Remark DSCP'.

  • WvandeHoefWvandeHoef Member Posts: 19  Freshman Member

    Thanks Rabbit, as far as I could tell congestion should not be the issue on this location. I am testing the recommended Wifi settings now to see if that resolves the situation, but I also am checking the ISP modem as they seem to change (or ignore) the DSCP levels in their network and forward all UDP traffic as Best Effort, completely ignoring the AF41 levels. Discussion with them is ongoing.

Sign In to comment.