Trunks, VLAN, and uplinks.

Hello. I'm coming from an HP/Cisco background but I'm running into issues getting this GS1900-10HP switch connected to my network.

For this switch I'm concerned with three VLAN.

VLAN 1 - Default VLAN, the switch has an IP on this VLAN.

VLAN 60 - VOIP VLAN.

VLAN 150 - DATA VLAN.

The switch works fine connected to my HP switch via port 1, I can ping it and log into the menu. Under VLAN Port I have it untagged on VL1, and tagged on VL 60-150. Very HP'ish.

Now on port 2 I want to have a PC and a VOIP Phone. Normally on HP I'd have it untagged on VL150 and tagged on VL60 so I set it the same. I have it connected like this, Switch>phone>PC.

The phone works. But I cannot connect to the PC.

So to sum it up VLAN are as follows.

VL1 - Untagged 1, 2-8 excluded

VL 60 - Tagged 1-8

VL 150 - Tagged 1, Untagged 2-8

Port 1 is set as a VLAN Trunk as well. Do I need to set a PVID on each port?

All Replies

  • Zyxel_LuciousZyxel_Lucious Zyxel Official Agent Posts: 149  mod
    edited November 6, 2019 12:12PM

    Hi @Aaron_W


    Based on your description, you should also

    1) Set PVID 150 on port 2 for ingress untagged packets from the PC.

    2) Set the VoIP phone tagged-out VLAN 60.


    Zyxel_Lucious

    Aaron_W
  • Fixed it. Had a tag wrong on int 1. Thanks for the help.

  • Aaron_WAaron_W Member Posts: 5
    edited November 7, 2019 1:43AM

    Spoke too soon. Got the PC connected on port 2. But now the phone isn't working.

    The Voice VLAN is set for VLAN 60.

    Its tagged on all ports on the switch. But my phone on port 2 cannot be reached now.

    The Phone is connected to port 2, then the PC connects via the IP Phones PC port. So now my situation is reversed.

    Port 1 is my trunk port, untagged VL1, tagged VL 60 & 150.

    Port 2 is untagged VL 150, tagged VL 60.

    The phone now cannot reach its SIP proxy on the same VLAN and I cannot ping it.

    Here is the setting via the CLI


  • I reset the switch and reconfigured it. I notice that it is now keeping VL60 as its Voice VLAN. PC works, phone still isn't working. These are on port 2.

    Here is the config.

    GS1900# sh run

    ! System Description: ZyXEL GS1900-10HP Switch

    ! Revision: A1

    ! Serial Number: S172L07003012

    ! MAC Address Range: B8:EC:A3:26:D0:53 - B8:EC:A3:26:D0:5D

    ! Boot Version: V2.00 | 07/17/2015

    ! Firmware Version: V2.40(AAZI.2) | 06/05/2019

    ! System Up Time: 0 days, 0 hours, 32 mins, 57 secs

    !

    !

    !

    ip address 172.16.1.38 mask 255.255.255.0

    ip default-gateway 172.16.1.81

    ip dns 172.16.2.1

    username "admin" secret encrypted 1N4D/wJ51UFHVOFLzBJQhg==

    username "aaron" secret encrypted SUuSVC18V6KHNc8Unu6/oQ==

    vlan 60

     name "VOIP0060"

    vlan 150

     name "SHOP0150"

    voice-vlan vlan 60

    voice-vlan

    voice-vlan oui-table 00:E0:BB "3COM"

    voice-vlan oui-table 00:03:6B "Cisco"

    voice-vlan oui-table 00:E0:75 "Veritel"

    voice-vlan oui-table 00:D0:1E "Pingtel"                                                                                                                    

    voice-vlan oui-table 00:01:E3 "Siemens"

    voice-vlan oui-table 00:60:B9 "NEC/Philips"

    voice-vlan oui-table 00:0F:E2 "H3C"

    voice-vlan oui-table 00:09:6E "Avaya"

    voice-vlan oui-table 00:0F:D3 "Digium"

    !

    !

    !

    !

    !

    spanning-tree mst configuration

     name "B8:EC:A3:26:D0:53"

    !

    !

    !

    no snmp community "public"

    snmp community "Nonpublic" ro

    !

    !

    !

    !

    !

    management access-list default

    !                                                                                                                                                          

    interface lag1

     switchport hybrid allowed vlan add 60 tagged

     switchport hybrid allowed vlan remove 1

    !

    interface lag2

     switchport hybrid allowed vlan add 60 tagged

     switchport hybrid allowed vlan remove 1

    !

    interface lag3

     switchport hybrid allowed vlan add 60 tagged

     switchport hybrid allowed vlan remove 1

    !

    interface lag4

     switchport hybrid allowed vlan add 60 tagged

     switchport hybrid allowed vlan remove 1

    !

    interface lag5

     switchport hybrid allowed vlan add 60 tagged

     switchport hybrid allowed vlan remove 1

    !

    interface lag6

     switchport hybrid allowed vlan add 60 tagged

     switchport hybrid allowed vlan remove 1

    !                                                                                                                                                          

    interface lag7

     switchport hybrid allowed vlan add 60 tagged

     switchport hybrid allowed vlan remove 1

    !

    interface lag8

     switchport hybrid allowed vlan add 60 tagged

     switchport hybrid allowed vlan remove 1

    !

    interface 1

     switchport hybrid vlan-trunking

     switchport hybrid allowed vlan add 60,150 tagged

    !

    interface 2

     switchport hybrid pvid 150

     switchport hybrid allowed vlan add 60 tagged

     switchport hybrid allowed vlan add 150 untagged

     switchport hybrid allowed vlan remove 1

     voice-vlan

    !

    interface 3

     switchport hybrid allowed vlan add 60 tagged

     switchport hybrid allowed vlan add 150 untagged

     switchport hybrid allowed vlan remove 1

     voice-vlan                                                                                                                                                

    !

    interface 4

     switchport hybrid allowed vlan add 60 tagged

     switchport hybrid allowed vlan add 150 untagged

     switchport hybrid allowed vlan remove 1

     voice-vlan

    !

    interface 5

     switchport hybrid allowed vlan add 60 tagged

     switchport hybrid allowed vlan add 150 untagged

     switchport hybrid allowed vlan remove 1

     voice-vlan

    !

    interface 6

     switchport hybrid allowed vlan add 60 tagged

     switchport hybrid allowed vlan add 150 untagged

     switchport hybrid allowed vlan remove 1

     voice-vlan

    !

    interface 7

     switchport hybrid allowed vlan add 60 tagged

     switchport hybrid allowed vlan add 150 untagged

     switchport hybrid allowed vlan remove 1

     voice-vlan                                                                                                                                                

    !

    interface 8

     switchport hybrid allowed vlan add 60 tagged

     switchport hybrid allowed vlan add 150 untagged

     switchport hybrid allowed vlan remove 1

     voice-vlan

    !

    interface 9

     switchport hybrid allowed vlan add 60 tagged

     voice-vlan

    !

    interface 10

     switchport hybrid allowed vlan add 60 tagged

     voice-vlan

    !

    !

    !

    !

  • Zyxel_DerrickZyxel_Derrick Zyxel Official Agent Posts: 52  mod

    Hi @Aaron_W


    Please try to configure IP phone's VLAN to VLAN 60 and test if the issue still exist.

    Thanks for your help


    Zyxel_Derrick

  • The IP Phone is on VL60 in its network settings. The switch can ping the phone server but the switch cannot pass traffic from the phone on tagged VL60.

Sign In to comment.