OSPF Configuration

I have 2 router with 2 wan ports and lan1. I am having trouble getting OSPF to work. I tried on CLI and web base and still nothing
Router 1
wan 1: 180.10.10.1
wan2: 190.10.10.1
lan 1: 192.168.10.10.1

Router 2
wan 2 180.10.10.2 
wan 2 190.10.10.2
lan 1 192.168.20.1


Here is my configuration on cli on Router 1
router ospf
router_id 128.0.0.1
network wan area 180.10.10.1
network wan2 area 190.10.10.1
network lan1 area 192.168.10.1

Router 2 
router_id 128.0.0.2
network wan area 180.10.10.2
network wan2 area 190.10.10.2
network lan1 area 192.168.10.2

Help.....?

All Replies

  • Ian31Ian31 Member Posts: 137  Ally Member
    @Kade ,
    It's important to have a topology drawing with area scope to discuss OSPF. 
    So, what's your Area design ?
    (1) A single Area ?

    R1:
    router ospf
    area 0.0.0.0
    router_id 128.0.0.1
    network wan1 area 0.0.0.0
    network wan2 area 0.0.0.0
    network lan1 area 0.0.0.0
    R2:
    router ospf
    area 0.0.0.0
    router_id 128.0.0.2
    network wan1 area 0.0.0.0
    network wan2 area 0.0.0.0
    network lan1 area 0.0.0.0

    (2) Multiple Area ? (Where the Area 0 scope ?)

    R1:
    router ospf
    area 0.0.0.0
    area 0.0.0.1
    router_id 128.0.0.1
    network wan1 area 0.0.0.0
    network wan2 area 0.0.0.0
    network lan1 area 0.0.0.1

    R2:
    router ospf
    area 0.0.0.0
    area 0.0.0.2
    router_id 128.0.0.2
    network wan1 area 0.0.0.0
    network wan2 area 0.0.0.0
    network lan1 area 0.0.0.2

    warwickt
  • KadeKade Member Posts: 8
    Thanks you, your explanation does help a lot. I set up a simple lab with 2 routers: R1 and R2. Those routers are connected to each other on the wan port but I cannot ping R2 wan interface from R1 wan interface. Then I set up a static routing on both router like you normally do in CISCO router but still nothing.What am I missing?
  • Ian31Ian31 Member Posts: 137  Ally Member
    @Kade,
    To simplify the lab.
    You can disable the firewall, to allow ping the wan & lan IP address from WAN side.
    (config)# no firewall activate
    (config)# write

    And disable the default source NAT(for lan to wan traffic), to run in routing mode without PAT.
    (config)# no system default-snat
    (config)# write

  • KadeKade Member Posts: 8
    Thank for your answer, I thought I was crazy because I couldn't figure it out why it was not working.. I will save your name for future questions.

Sign In to comment.