GS1920v2-8HP - credentials are in plaintext

ChristianGChristianG Member Posts: 137  Ally Member
Hi ZYXEL Support Team,
i rebuild a configuration on a GS1920v2 today and a bit confused, that all data (sensitive e.g. admin credentials) are stored in plain text in the config file of a GS1920v2-8HP Switch :o

such information is normaly stored encrypted in a config backup (e.g. like with the USG accounts)
All other parameter can be stored in cleartext but not the admin credentials ;)

Device Information
Firmware: V4.50(ABKZ.2) | 08/30/2018
HW-Revision: 2.0
Modus: Standalone mode

Thx forward for your response
Christian




Alfonso

Best Answer

Answers

  • AlfonsoAlfonso Member Posts: 143  Ally Member

    All other parameter can be stored in cleartext but not the admin credentials ;)



    I totally agree @[email protected]

    But other parameters should not be stored in cleartext.
    For example radius authentication password.

    So Zyxel should analyze what kind of information is stored in cleartext and how to encrypt it.

    Regards
    ChristianG
  • ChristianGChristianG Member Posts: 137  Ally Member
    edited December 24, 2018 2:24AM
    @Alfonso ,
    totaly agree to your post. if you have a USG with an old firmware, the SSID and depenting  credentials for the SSID where also stored in plaintext in the config file :/
    The USG accounts where decrypted.

    So in my mind, they should use the decryption module as in the USG to have not a lot off different modules for decryption =)

    Regards
    Christian
  • Zyxel_JonasZyxel_Jonas Zyxel Official Agent Posts: 65  mod
    Hi @ChristianG,

    We had an internal meeting regarding this case.
    The encrypted password for GS1920v2 series admin credentials had already added in Zyxel future roadmap and already listed in the Idea section.

    Thanks for your advice.
    Jonas
  • ChristianGChristianG Member Posts: 137  Ally Member
    edited December 24, 2018 8:30PM
    @Zyxel_Jason
    is there also a known issue to restore a saved configuration file at a GS1920v2 ?
    i got the error in line 5 "telnet commant" that stoped the restore and i had to reconfigure the switch from factory default to the documentated configuration as described in the System Operation Handbook (SOHB).

    The switch had only a hand of vLANs in the uplink, changed admin / snmp credentials and no special settings.
     
    Thanks and regards
    Christian
Sign In to comment.