[NEBULA] two-factor and mobile app

FrankIversenFrankIversen Member Posts: 92  Ally Member
edited January 8, 2021 5:40PM in Nebula General Discussion
We are strulling that when trying to login to the app we get a confirmation mail, click it, but still can't log in.
Using android mobile.

Any ideas? Perhaps a app-password?


  • Nebula_JasonNebula_Jason Zyxel Offical Agent Posts: 217  mod

    Currently, Two-Factor Authentication can only available by using Google Authenticator since there is an issue on the email verification link.
    We will change the whole email verification from using a URL to a verification code to avoid this issue on APP in the future.

    The workaround for you now is to use Google Authenticator or disable it.
    Here is the procedure to do that:
    2. Click "Account" and find "Two-Factor Authentication".
    3. Select "Google Authenticator" or "Disable" and click "Apply".

    You may also refer to our FAQ link Here to see the steps more clearly.

    Hope it helps.
  • Nebula_JasonNebula_Jason Zyxel Offical Agent Posts: 217  mod
    Hi @FrankIversen,

    Please note that the symptom for the confirmation mail only happens when the user logins Nebula via Mobile APP.
    Therefore, Two-Factor Authentication with E-mail Verification is still workable when you login via Browser.
  • TAPTechTAPTech Member Posts: 86  Ally Member

    I'm using 2 Factor Authentication via Google Auth, but when I log in with the Android Nebula app, it simply says my password is wrong.  Is there a fix?
  • Nebula_JasonNebula_Jason Zyxel Offical Agent Posts: 217  mod
    Hi @TAPTech,

    I have signed in my account to Android Nebula APP by 2-Factor Authentication with no issue.
    Which password you get the "wrong" message? The account password or the Google Authenticator PIN code?

    If you forget your account password, you may click "Forget Password" on the login page and follow the procedure to set up new password.
    If you have encountered problems when using Google Authenticator, you may enter your backup codes to login.

    Hope it helps.
  • TAPTechTAPTech Member Posts: 86  Ally Member
    Hi Jason,

    I logged into myzyxel.com and disabled 2FA.  I was then able to log into the Android Nebula app with just my password.  After thinking about your post, I simply enabled 2FA at myzyxel.com again.  After that, it worked on the app!

    I have had 2FA enabled on myzyxel.com for a while, perhaps it was just timing.  After I logged into the app, I was adding devices very quickly.  I have to say.... Nebula is awesome!

    Thank you Jason for your quick reply... this one is solved!

Sign In to comment.