XGS4600 DHCP Global relay

maxsafmaxsaf Member Posts: 11  Freshman Member
We have an issue with DHCP relay on XGS4600.
Step 1. Global relay is disabled, client not getting IP from DHCP server.
Step 2. Global relay enabled, first address changed to our DHCP IP. Client getting proper IP.
Step 3. Global relay first address changed back to default 0.0.0.0. Client getting IP (???)
Step 4. Global relay disabled. Client still getting IP (?????)
Step 5. Switch Reboot. Client not getting IP.

Comments

  • Zyxel_RyanZyxel_Ryan Zyxel Official Agent Posts: 66  mod
    Hi @maxsaf

    From your description, you are trying to configure the setting below, right?
    (IP Application> DHCP> DHCPv4> Global)


    I am not very clear about your question, could you explain it more clearly? 
    Is your problem: 
    a) Global relay is enabled. Client can get DHCP IP at the beginning, but after a while changed back to 0.0.0.0?
    b) Global relay is disabled, but client still get IP?  

    Ryan
  • maxsafmaxsaf Member Posts: 11  Freshman Member
    Yes, i'm using IP Application> DHCP> DHCPv4> Global

    Step 3. i'm changing dhcp server ip to 0.0.0.0 then click apply. client still able to get IP.  Why?
    b) Global relay is disabled, but client still get IP?  Yes
  • maxsafmaxsaf Member Posts: 11  Freshman Member
    UPD: Another issue: If DHCP relay not Active (disabled)  i can not enable DHCP server while Remote DHCP Server  and Option 82 not DEFAULT. 
  • Zyxel_RyanZyxel_Ryan Zyxel Official Agent Posts: 66  mod
    edited May 3, 2018 1:42PM
    Hi @maxsaf

    I have some questions.
    1. How do you make your PC to get DHCP IP again? 
        a) By using ipconfig /release and then ipconfig /renew? 
        b) Unplug and Plug connection
    2. Do you have router which can route packets between PC and DHCP server? 

    Ryan
  • maxsafmaxsaf Member Posts: 11  Freshman Member
    1. My DHCP client is not a PC. It is a Mikrotik router. I'm getting new IP by Renew command, by disable/enable DHCP Client on Mikrotik router, also by enable/disable interface with DHCP client. Each time i see on DHCP client Discovery and Request, on DHCP server i see proper Offer and Ack. That log also shows DHCP relay IP during process.
    2. Yes i have two routers between client and server. First router that is relay itself (XGS4600). Second one - Mikrotik 1072. Traceroute shows three hops from client to server and from server to client. There is no L2 connection  between Client and Server
  • Zyxel_RyanZyxel_Ryan Zyxel Official Agent Posts: 66  mod
    Hi @maxsaf

    Based on your description, I assume your topology is below. Am I right? 


    If I am right, does DHCP Request packet from DHCP Client unicast to DHCP Server?   
    (If you are not very sure, please provide IP address of each member and PM me your packets. I will check for you.)

    Ryan
  • maxsafmaxsaf Member Posts: 11  Freshman Member
    That topology is correct. DHCP server it is another one Mikrotik 1072. Will PM you with LOGs
  • Zyxel_RyanZyxel_Ryan Zyxel Official Agent Posts: 66  mod
    Hi @maxsaf

    Thanks for your information!
    As the discussion, we can also reproduce this problem now.
    Only certain orders will trigger this problem. Like your steps, set Server IP to 0.0.0.0 firstly and then disable global relay will trigger this problem. 
    To prevent the problem, we suggest to disable your global relay firstly and then change server IP to 0.0.0.0. In this case, you will be able to disable Global Relay successfully. 

    We plan to fix the problem in next firmware, which will be released in 2019 Q1. 

    Ryan
Sign In to comment.