USG60 4.3 and 4.31 VOIP constant problems - gave up and downgraded to 4.25

Gary_fromDenverGary_fromDenver Member Posts: 4  Freshman Member
Anyone else have constant issues with VOIP and 4.3 => 4.31 Firmware?  Solutions other than downgrading FW?Bought USG60, came with 4.25, upgraded to 4.3, had constant problems with losing sessions and audio.  Upgraded to 4.31 and solved some issues but packet headers changed by Zyxel Firewall so ongoing issues of conference calls denied.
-----------Layout------------
Vitelity SIP Trunk hosted FreePBX server
7 Cisco SPA VOIP phones behind USG60 Router and segregated to VLAN. 
Upgrading to 4.31(AAKY.0) resolved a lot of VOIP lost audio/connection/session issues .  4.31 still changed packet headers so PBX lost originating extension.
Spent huge time and $ with IT and couldn't get it resolved.
Gave up and downgraded to 4.25 firmware with no apparent VOIP issues including conference calls. 
«1

Comments

  • Zyxel_CooldiaZyxel_Cooldia Zyxel Official Agent Posts: 258  mod
    Hi @Gary_fromDenver,
    Can you post this command result.
    Router> show alg sip
  • Zyxel_CooldiaZyxel_Cooldia Zyxel Official Agent Posts: 258  mod
    Hi @Gary_fromDenver,
    Some short questions about this issue.
    1) Upgraded to 4.3, had constant problems with losing sessions and audio.
      [Are both Caller and Callee in the USG LAN side? or one is USG wan side, another is LAN side?]
    2) Upgraded to 4.31 and solved some issues but packet headers changed by Zyxel Firewall so ongoing issues of conference calls denied.
      [Could you provide packet trace via private message (when you are calling, capture from wan and LAN interface).]
    3) Can you post this command result. Router> show alg sip. We would like to know the sip alg configuration.


  • Gary_fromDenverGary_fromDenver Member Posts: 4  Freshman Member
    GroKit wrote:
    @Gary_fromDenver, yes .. just look here: https://businessforum.zyxel.com/discussion/1093/4-30-sip-alg-issues
    -----------------------------------------------------------
    GroKit has good thread, please read.  My IT guy will respond to Zyxel-CoolDia in the next few days but GroKit has excellent thread!!
  • jrbconsultjrbconsult Member Posts: 1  Freshman Member
    @Zyxel_Cooldia:

    I am the IT/PBX support for @Gary_fromDenver.  I can try to answer your questions the best I can, but as we are running 4.25 currently, I cannot give you a SIP trace demonstrating the issues.  We ended up turning off SIP ALG entirely and let the PBX and the phones handle their SIP traffic on sequential SIP ports (5060, 5061, 5062, etc.)   This works flawlessly as of right now.  RTP media is also fine.

    Most of the affected phones are on the USG LAN side.  There are a few other phones that reside at remote locations, however.  They connect to the PBX at another remote location (WAN side of the USG.)  

    Setup looks like this:

    PBX
     |----------------|
    USG        Remote extensions
     |
    Office Phones

    As Gary stated, everything was fine on 4.25 WITHOUT ALG, but when we switched to 4.30, with and without ALG, we ran into a ton of issues with dropped calls, mangled SIP headers using NAT addresses on the PBX rather than the WAN IP, sporadic one-way audio, and the like.  When 4.31 was available, we upgraded to that and most of the issues went away, but conferencing from the Cisco SPA phones was broken, as it seemed that the USG was still manhandling our SIP headers.  

    I can contact Gary and see if he can get you the output of the CLI info you requested, but I am hesitant to upgrade to a known problematic firmware just for testing, unless there is no other way you can get the info you need.

    Thank you,
    Jeremy


  • Zyxel_EmilyZyxel_Emily Zyxel Official Agent Posts: 269  mod

    @Gary_fromDenver

    I will private message the date firmware which solves the issue in the thread https://businessforum.zyxel.com/discussion/1093/4-30-sip-alg-issues.

    You can verify the issue at your site and see if it can solve the problem.

  • Zyxel_CooldiaZyxel_Cooldia Zyxel Official Agent Posts: 258  mod
    Hi @Gary_fromDenver,
    Just keeping follow up this case, Is the issue solved by the firmware that Emily gave to you?
  • Gary_fromDenverGary_fromDenver Member Posts: 4  Freshman Member
    No.  We aren't having any problems now that we downgraded to 4.25.  So we are going to keep it there.  No need to spend more time on this when 4.25 works great.  Thanks for the follow-up! Gary
  • triJROtriJRO Member Posts: 7
    We also have the Problem of losing Sessions between our Cloud VoIP Provider and phones. Currently using 4.33 on our Zywall 110. Did someone upgrade from the 4.25 Version to a newer Version without Problem or is 4.25 still the only option? Could someone give me the Files for 4.25 so I can perfrom a Downgrade too? 

    Thanks in advance 

    Jann
  • Gary_fromDenverGary_fromDenver Member Posts: 4  Freshman Member
    Jann,
    Don't downgrade.  Read the Tech notes for VOIP settings and follow the recommendations exactly.  It will solve your problems!  Gary
Sign In to comment.